Messenger+ Installation

Messenger requires that you have Citrix Receiver (or Workspace) on your PC, Tablet, or Phone.

If you already have a version of Citrix installed, the version you have should be compatible.

We recommend the latest LTSR version (Citrix link to latest LTSR download here). We recommend you contact your IT department for assistance in this installation.